Why is it asking for the project name, even though I am specifying it already?

I am using it in HPC interactive mode,where I have specified the project name.

qsub -I -P iwaves.spons -q standard -lselect=1:ncpus=4 -lwalltime=02:59:00

However, when using the code,

`from dask_jobqueue import PBSCluster

cluster = PBSCluster(cores=2,


from dask.distributed import Client
client = Client(cluster) `

even though I am mentioning the project, why is it showing this error “qsub: Project not specified.Please specify the Project by “-P ””?

Hi @InternalWaves, welcome to Dask Discourse forum!

project kwarg in all Cluster classes of dask-jobqueue is misleading. It has been replaced by account, as it was used to position -A PBS option (see there). You probably have a warning about that before the Error.

You could also verify this by printing the job script that would be submitted to PBS:


I admit the kwarg should now be removed entirely from dask-jobqueue, we need to do this in a future release.

In your case, you’ll need to use job_extra_directives kwarg in order to configure your project.

Thanks a lot, it’s sorted now.

1 Like