Can we set nanny host as


I am trying to restart a remote worker from a scheduler in different machine. Both scheduler and worker are running in a docker container. However, I am having difficulty as nanny host is published to scheduler as the wrong ip address.

I am creating worker using the dask-worker cli command. Is there any way to specify the correct nanny host from cli?


Hi @longshort,

Looking at the documentation, there are three options you could use: --listen-address and --contact-address, or even --host.

Hi @guillaumeeb ,

Thank you for your reply. I am currently using --listen-address and --contact-address which advertises the correct address for the worker. However, this does not change the address that nanny advertises to the scheduler.

To illustrate, the worker starts listening at the private ip of the EC2 instance, at interface eth0. However, the nanny is started at the ip address of the interface docker0. The worker can connect to scheduler, but I am not able to do client.restart() for example, as the nanny is unreachable.

I tried to use --host to set address as private ip, but I am getting “Nanny Failed to start”, “cannot assign requested address”.

I am wondering if there is any other way to solve this issue.


Do you think you could use the --interface option?

In any case, this might be a new feature or even a bug, it is a bit weird that Nanny doesn’t use the contact-address too.